Delayed Ad Publication

Incident Report for Kevel

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 14:31 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 08, 2025 - 14:30 EDT

Update

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2025 - 14:11 EDT

Investigating

We identified an issue impacting ad publication starting 2025-06-08 16:00 UTC. An investigation is underway with our team. We'll keep you updated along the way.
Posted Jun 08, 2025 - 14:09 EDT
This incident affected: Ad Serving.