Reporting - Delayed Ingestion

Incident Report for Kevel

Resolved

Confirming the ingestion of the delayed reporting data is now complete and this is now resolved.

Newly created reports will contain correct and up to date metrics from December 2 - 3.
Posted Dec 03, 2025 - 17:01 EST

Monitoring

A fix has been implemented and we are monitoring results. We expect that it will take around 8 hours for the ingestion of the delayed reporting data to be completed. Once completed, the temporarily missing reporting data from December 2 - 3 will be available.
Posted Dec 03, 2025 - 14:22 EST

Update

Work is still in progress on the fix for delayed data ingestion. We will update again as soon as we have further progress to share.
Posted Dec 03, 2025 - 11:48 EST

Identified

The issue has been identified and a fix is in-progress.

To further clarify the impact, some customers may be temporarily missing data from December 2 - 3, as the ingestion of this data is delayed.
Posted Dec 03, 2025 - 09:33 EST

Investigating

We are investigating an issue with delayed reporting data ingestion that is causing degraded reporting performance. Some customers may experience missing data in reports for December 2 - 3.
Posted Dec 03, 2025 - 09:09 EST
This incident affected: Reporting.